REQUERIMIENTOS PARA INSTALAR MOODLE

 

Servidor web con soporte a PHP y base de datos (MySQL o PostgreSQL)

Una instalación de PHP en funcionamiento (versión 4.3.0 o posterior). PHP 5 está soportado a partir de Moodle 1.4. (tenga cuidado con PHP-Accelerator ya que se han detectado problemas con él.

Una base de datos: MySQL o PostgreSQL, que están completamente soportadas y recomendadas para su uso con Moodle. MySQL es la elección preferida para mucha gente porque es muy popular, pero hay algunos argumentos a favor de PostgreSQL, especialmente si está planificando instalaciones de grandes dimensiones. MySQL 4.1.16 es la versión mínima para trabajar con Moodle 1.6 (muchas distribuciones de Linux incorporan versiones más antiguas, así que debe comprobar este extremo).

La mayoría de los servicios de alojamiento web (hosting) soportan todo esto por defecto.

 

Requerimientos Adicionales

Librería GD y librería FreeType 2 para poder construir los gráficos de los registros de Moodle.

mbstring – es requerido para manipular cadenas de caracteres multi-byte (iconv también es recomendable para Moodle 1.6).

la extensión mysql si va a utilizar la base de datos MySQL. En algunas distribuciones de Linux (principalmente RedHat) se trata de un paquete opcional.

La extensión pgsql si va a utilizar una base de datos PostgreSQL.

La extensión zlib es necesaria si va a utilizar las funcionalidades zip/unzip.
Otras extensiones PHP podrían ser necesarias dependiendo de las funcionalidades opcionales de Moodle que vayan a ser utilizadas, especialmente las relacionadas con autenticación y matriculación (p. ej. la extensión LDAP).
[Volver]
Leave Comment